• Deutsch
  • English

Landschaften & Berge mit Hilfe von Blender

  

Inhaltsverzeichnis

  1. Einleitung
  2. Downloads
  3. Vorbereitungen
  4. Shortcuts
  5. Einen Berg modellieren
  6. Export als PNG
  7. Nachbearbeitung des exportierten Bildes
  8. Import im 3D-Modellbahn Studio
  9. Tipps und Tricks

1. Einleitung

Egal ob mit Tapetenkleister und Zeitungspapier oder mit Tastatur und Maus, eines ist geblieben. Mein fehlendes Talent wenn es darum geht natürlich aussehende Geländeformen zu modellieren. Was lag also näher als aus der Not eine Tugend zu machen und mich nach passender Software umzuschauen. Gute und zum Teil auch kostenlose Software wie z. B. Vue Pioneer oder Bryce 5 liefern (Einarbeitung in das Programm vorausgesetzt) sehr schöne Ergebnisse. Allerdings in Form von 3D-Objekten. Da bei einer "vernünftigen" Landschaft schnell mehrere tausend Flächen zusammenkommen war klar, dass der Weg nur über das Modellieren der Grundplatte des Modellbahnstudios geht da bei dieser Vorgehensweise keine zusätzlichen Flächen entstehen. Einen ersten Teilerfolg konnte ich verbuchen als ich über das Plugin "ANT Landscape" stolperte (Standard in Blender). Allerdings nur ein Teilergebnis, denn um das Ergebnis als Graustufenbild (Heightmap) zu exportieren waren sehr viele weitere Schritte nötig. Nachhaltigere Nachforschungen im Internet führten mich zu einem weiteren Plugin. "Export Heightmap". Vermutlich von einem findigen Kopf programmiert dem die Standardvorgehensweise ebenfalls zu umständlich war. Was wir also brauchen:

  1. Unser Modellbahnstudio (für dieses Tutorial genügt auch die Standard-Version)
  2. Das kostenlose Blender
  3. Das kostenlose Plugin "Export Heightmap"
  4. Ein Grafikprogramm wie z. B. das kostenlose Gimp

Berge zum Nulltarif. Was will man mehr.

Für das Modellieren der Bodenplatte verwenden wir in diesem Tutorial Heightmaps. Deutsch: Graustufenbilder oder Höhenfelder bei denen jedem Helligkeitswert eine Höhe zugeordnet wird. Genaueres hierzu liefert uns Wikipedia.

 

2. Downloads

 

  • Was wir uns aus dem Internet besorgen müssen ist Blender. Welche Version (32 Bit, 64 Bit, als Installer oder als Portable) spielt keine Rolle. Aber es sollte die aktuelle Version sein da Blender erst vor kurzem "eingedeutscht" wurde und wir das Programm im weiteren Verlauf auf Deutsch umstellen werden.
  • Dann das Plugin um die Graustufenbilder exportieren zu können. Stört euch nicht an der auf dieser Seite angegebene Blender-Versionsnummer 2.5. Das Plugin funktioniert auch in Blender 2.6x. Die ZIP in ein beliebiges Verzeichnis entpacken. Wir kommen später darauf zurück.
  • Und ein Grafikprogramm. Ich gehe davon aus, dass sich auf jedem Rechner etwas passendes findet. Für die Unentschlossenen empfehle ich (da keine Installation nötig ist) Gimp. Ein Alleskönner zum Nulltarif der zum Teil mit Plugins von Photoshop klarkommt.

3. Vorbereitungen

Ich denke, auf die Installation und das Starten von Programmen müssen wir nicht weiter eingehen. Starten wir also Blender und richten die Software nach unseren Bedürfnissen ein. Blender bietet eine Unzahl von Möglichkeiten der Programmanpassung. Wir beschränken uns hier nur auf ein paar wenige.

Nach dem ersten Start zeigt sich Blender in etwa so:

Wir wollen die Einstellungen ändern. Die Einstellungen erreichen wir über das Menü "File / User Preferences...".

Wir "landen" in diesem Fenster:

Wir wollen uns, wie Eingangs erwähnt, auf die wichtigsten Sachen beschränken, also wechseln wir sofort zum Reiter "Input". Da wir z. B. vom 3D-Modellbahn Studio gewohnt sind Objekte mit der linken Maustaste zu markieren wollen wir Blender auch auf diese Art bedienen. Also klicken wir auf die markierten Buttons:

Wir wollen Berge erschaffen! Also geht es weiter zum Reiter "Addons". Nachdem wir, der besseren Übersicht halber, auf der linken Seite "Add Mesh" angeklickt haben, können wir rechts das Addon "ANT Landscape" aktivieren.

An dieser Stelle installieren wir auch unser Addon "Export Heightmap". Mit einem Klick auf den Button "Install from File..." rufen wir diese Prozedur auf in der wir uns in das Verzeichnis unseres entpackten Addon klicken und das Addon mit einem Doppelklick übernehmen um es abschließend, wie im folgenden Bild zu sehen, zu aktivieren.

Fast geschafft. Fehlt nur noch die Umstellung auf Deutsch. Dazu die markierten Buttons anklicken:

Bevor wir dieses Fenster schließen unbedingt einen Klick auf "Benutzereinstellungen speichern" ausführen da wir ansonsten bei jedem Blender-Neustart die Einstellungen wiederholen müssten.

Wer es vorzieht Blender grundsätzlich ohne diesen "lästigen Würfel" zu starten kann nun mit der linken Maustaste den Würfel markieren um ihn mit der Taste "Entf" oder "X" zu löschen. Dann sollten allerdings noch einmal die (jetzt in Deutsch) "Benutzereinstellungen..." aufgerufen und dort noch einmal der "Benutzereinstellungen speichern" Button angeklickt werden.

Damit ist die Konfiguration von Blender abgeschlossen. Blender bietet noch wesentlich mehr Optionen die für unser Vorhaben jedoch keine Rolle spielen. Solltet ihr Fragen dazu haben schreibt mir eine Nachricht im Forum.

4. Shortcuts

Auch wenn die Blender-Oberfläche seit der Version 2.5 wesentlich anwenderfreundlicher wurde ist es doch ratsam bestimmte Befehle per Shortcut auszuführen. Deshalb an dieser Stelle noch ein paar nützliche Tastaturbefehle:

Blender hat die besondere Eigenschaft, dass sich alle Shortcuts nur dann auswirken wenn sich der Mauszeiger innerhalb des 3D-Fensters befindet.

Auf dem Nummernblock:

 = Ansicht von Oben
= Ansicht von Unten

= Ansicht von Vorne
= Ansicht von Hinten

= Ansicht von Rechts
= Ansicht von Links

= Umschalten zwischen Orthogonaler und Perspektivischer Ansicht

= Zoomen auf markiertes Objekt

Auf der alphanumerischen Tastatur:

= Ausblenden der Objektwerkzeuge auf der linken Seite

= Ausblenden der Parameterleiste auf der rechten Seite

= Umschalten der Objektdarstellung Massiv / Drahtgittermodell

= Löschen des markierten Objekts

Navigation im 3D Fenster

Rotieren = Mausbewegung bei gedrückter Mittlerer Maustaste
Bewegen = Mausbewegung bei festgehaltener, linker Shift-Taste und gedrückter mittlerer Maustaste

5. Einen Berg modellieren

Bevor wir mit einem Klick einen Berg erschaffen sorgen wir für eine einheitliche Oberfläche. Bitte folgendes kontrollieren:

  • Wenn auf der linken Seite KEIN Menü zu sehen ist dann dieses Menü durch Drücken der Taste "T" einschalten. Für die folgenden Einstellungen wird nur dieses Menü benötigt.
  • Wir möchten möglichst viel von unserem Berg sehen. Wenn das Menü "Transformieren" auf der rechten Seite angezeigt wird können wir es abschalten indem wir die Taste "N" benutzen. Das verbleibende letzte Menü auf der rechten Seite kann nicht abgeschaltet werden.
  • Sollte der Würfel noch zu sehen sein dann bitte markieren und über "X" oder "Entf" löschen.

So sollte unser Bildschirm nun in etwa aussehen:

Unseren ersten Berg fügen wir ein indem wir auf das Menü "Einfügen" klicken, den Mauszeiger auf den Menüpunkt "Mesh" bewegen und weiter auf den untersten Punkt "Landscape".

Bitte schön, unser erster Berg:
 

Es gilt nun, diesen Berg mit möglichst wenig Aufwand unseren Bedürfnissen anzupassen. Dazu bietet uns Blender viele Parameter an die sich im Moment wahrscheinlich noch "verstecken". Wenn das Menü unten links in etwa so aussieht:

können wir es an der markierten Linie anklicken und bei gedrückt gehaltener Maustaste so weit nach oben ziehen bis alle Parameter sichtbar sind.

Die Parameterliste kann auch durch Drücken der Taste "F6" angezeigt werden. Diese Liste ist identisch mit der Liste auf der linken Seite. Allerdings macht sich beim Arbeiten mit der F6-Parameterliste eine Eigenart von Blender bemerkbar. Sobald wir mit dem Mauszeiger den Bereich dieser Liste verlassen schließt sich dieses Fenster automatisch. Diese Automatik ist von Blender beabsichtigt denn Blender ist so programmiert, dass es dem Benutzer möglichst viele Klicks abnimmt was in unserem Fall bedeutet, dass, wenn wir die Liste mit dem Mauszeiger verlassen, Blender davon ausgeht, dass wir mit der Bearbeitung fertig sind und uns die "Arbeit" des Fensterschließens abnimmt. Für uns bedeutet dies, wenn wir die Liste versehentlich geschlossen haben rufen wir sie wieder in den Vordergrund indem wir erneut die Taste F6 drücken. Die linke, obere Ecke dieses Menüs erscheint übrigens immer dort, wo sich in diesem Moment der Mauszeiger befindet.

Liste der wichtigsten Parameter:

Weich: Dieser Parameter hat nichts mit der Form des Objektes zu tun sondern verändert wie das Objekt im 3D-Fenster angezeigt wird. Wenn wir im weiteren Verlauf den Parameter "Unterteilung" vergrößern werden wir, bei einem Wert von etwa 256 feststellen, dass Blender länger benötigt um die Landschaft neu zu berechnen. Dies liegt daran, dass Blender bei gesetztem Haken eine möglichst genaue Darstellung erzeugen will. Entfernen wir den Haken erfolgt der Bildschirmaufbau wesentlich schneller.

Wichtig: Hat nichts mit der Auflösung unseres Berges im 3D-Modellbahn Studio zu tun.

 

Unterteilung: Einer der wichtigsten Parameter ist der Parameter "Unterteilungen" denn er legt fest mit welcher Auflösung unsere generierte Landschaft im 3D-Modellbahn Studio importiert wird. Sehen wir uns unser Objekt etwas genauer an:

Unser Exporter, mit dem wir später ein Graustufenbild erzeugen wollen, richtet sich nur nach der Höhe der einzelnen Punkte. Die X und Y-Koordinaten interessieren nur insofern, dass jeder Punkt im 3D-Modellbahn Studio einem Rasterpunkt zugeordnet wird. Deshalb spielt es keine Rolle welchen Wert wir für die "Mesh Size" eingeben. Würden wir diesen Wert vergrößern erscheint das Objekt größer im Blender-3D Fenster. An der Anzahl der Rasterpunkte ändert sich dadurch nichts.

Keine Angst ! Egal wie hoch wir die Unterteilungen einstellen es wird im 3D-Modellbahn Studio keine einzige zusätzliche Fläche erstellt.

 

Random Seed: Sucht man im Internet nach einer Erklärung für diesen Parameter findet man z. B. "Erzeugt eine zufällig errechnete Landschaft". Diese Erklärung ist, meines Erachtens, verwirrend. Der Parameter geht, meiner Meinung nach, als Konstante in eine Formel ein mit der das Objekt berechnet wird. Also spielt der Zufall keine Rolle. Erzeugt man z. B. eine Landschaft mit dem Wert 1, dann eine mit dem Wert 7 und abschließend wieder Eine mit dem Wert 1 erhält man folgende Objekte:

Wie man sieht: Bei Parameter 1 entsteht immer das gleiche Objekt. Für uns interessant denn so können wir uns die Nummer eines besonders gut gelungenen Berges merken und ihn bei Bedarf erneut erzeugen.
 

Tiefe: Die Tiefe sagt aus wie zerklüftet die Landschaft berechnet wird. Die folgende Abbildung zeigt einen Ausschnitt einer 3D Landschaft mit einer Unterteilung von 512:

 

Höhe: Dieser Wert sagt aus, wie hoch unser Berg wird. Wir müssen uns an dieser Stelle noch nicht für eine endgültige Höhe entscheiden denn wir bekommen beim Import in das 3D-Modellbahn Studio die Möglichkeit festzulegen, mit welchem Faktor diese Werte eingehen.

Sollte ab einer bestimmten Höhe ein Plateau erzeugt werden, so ist der Wert "Höhe" größer als der Wert beim Parameter "Plateau".

 

Abfall: Dieser Parameter legt fest, wie "schnell" ein Berg abfällt. Dabei sind für uns die Parameter X und Y wichtig um ein Bergpanorama für den Hintergrund oder eine Seite zu generieren. Wie sich die verschiedenen Werte auswirken zeigen die folgenden Bilder:

Daran, dass Typ X bzw. Typ Y nach beiden Seiten abfällt stören wir uns im Moment nicht. Dieses Manko beseitigen wir später beim Import des Graustufenbildes in das 3D-Modellbahn Studio.

Anwender, die bereits etwas Erfahrung mit Blender haben könnten an dieser Stelle versuchen wollen, die nicht benötigten Flächen und Kanten gleich hier zu löschen. Ich hab's versucht. Geht leider nicht. Der Heightmap-Exporter funktioniert nur mit quadratischen Flächen.

Dies waren die wichtigsten Parameter. Eine Vorstellungen der vielen anderen Möglichkeiten ersparen wir uns. Hier rechne ich mit eurer Experimentierfreudigkeit.

6. Export als PNG

Der Export gestaltet sich recht einfach. Über das Menü "Datei / Exportieren / Heightmap" rufen wir den Vorgang auf. Der weitere Ablauf sollte selbsterklärend sein. Verzeichnis wählen, Exportieren anklicken. Fertig.

7. Nachbearbeitung des exportierten Bildes

Im Grunde ist der Ausdruck "Nachbearbeitung" fehl am Platz denn die Hauptaufgabe dieses Arbeitsschrittes ist das Umwandeln der exportieren PNG-Datei in ein Format das im 3D-Modellbahn Studio Verwendung findet. Das 3D-Modellbahn Studio unterstützt die Dateiformate JPG und BMP und es gibt unzählige Freeware-Programme, die die Umwandlung von PNG in eines dieser Formate unterstützen. Da ich davon ausgehe, dass jeder Anwender seinen "Spezialisten" für solche Aufgaben auf seinem Rechner installiert hat erspare ich mir eine genauere Beschreibung.

Ich empfehle zum Export das BMP-Format da es bei diesem Format nicht zu den bekannten Treppenbildungen kommen kann die bei JPG's entstehen.
Wird im nächsten Schritt, dem Import des Heightmap-Bildes ins 3D-Modellbahn Studio, festgestellt, dass die Ausrichtung nicht stimmt kann an dieser Stelle das Bild gedreht, neu abgespeichert , und erneut importiert werden.

Mit steigender Zahl an Unterteilungen benötigt Blender mehr Zeit um Neuberechnungen durchzuführen. Nun könnte man versucht sein, in Blender mit wenigen Unterteilungen zu arbeiten und die exportierte PNG-Datei im Grafikprogramm hochrechnen zu lassen. Dies ist zum Teil möglich sollte sich jedoch in Grenzen halten. Zur Veranschaulichung folgendes Beispiel:

Die folgende Abbildung zeigt ein Objekt in Blender mit 64 Unterteilungen und mit 512 Unterteilungen und es ist deutlich zu sehen, dass bei dieser Erhöhung Blender in der Lage ist Zwischenwerte zu berechnen die dann auch exportiert werden können.

Der Unterschied wird sehr deutlich wenn wir uns die Heightmaps nach den verschiedenen Vorgehensweisen (höhere Unterteilung in Blender und Hochrechnen mit Grafikprogramm) ansehen.

Und abschließend das Ergebnis im 3D-Modellbahn Studio nach dem Import der beiden unteren Bilder:

Hohe Unterteilungen in Blender oder Hochrechnen der Bilder mit einem Grafikprogramm? Ich denke diese Entscheidung hängt sehr stark von der Größe der Anlage ab. Muss ich den Framerates zuliebe ein gröberes Raster benutzen kann/muss ich auch eine gröbere Abstufung des Rasterbildes in Kauf nehmen.

8. Import im 3D-Modellbahn Studio

Kommen wir nun zum letzten Teil diesen Tutorials, dem Importieren der Graustufenbilder. Der Import bietet die Möglichkeit entscheidend auf die Darstellung des Geländes Einfluss zu nehmen. Die Import-Funktion findet sich nach einem Doppelklick auf die Grundplatte hier:

Zum ersten mal sehen wir die Auswirkungen unseres Graustufenbildes auf der Grundplatte des 3D-Modellbahn Studios. Selten wird der Höhenbereich 0 - 1000 zutreffen:

Also ändern wir den Wert 1000 auf z. B. 500 und erhalten diese Voransicht:

Schon wesentlich besser. Nun findet man auf vielen Modellbahnanlagen Schattenbahnhöfe. Die Import-Funktion des 3D-Modellbahn Studios unterstützt uns auch in dieser Beziehung. Es muss lediglich der linke Wert des Höhenbereiches angepasst werden:

Wird die linke Zahl des Höhenbereiches auf 200 erhöht (was einer Höhe eines Schattenbahnhofes mit 200 mm gleich kommt) so sollte auch der rechte Betrag um 200 erhöht werden da ansonsten die Höhe des Berges reduziert wird.

Die Ursprungswerte. Diese beiden Werte bestimmen die X und Y Koordinaten auf der Platte an denen die linke, obere Ecke unseres Graustufenbildes "sitzen" soll.

Für die Ursprungswerte sind auch negative Zahlen zugelassen. So ist es möglich nur einen Teil des Berges am Rand zu platzieren um somit einen Berg im Hintergrund zu erhalten!

Auch die gewählte Rastergröße der Bodenplatte beeinflusst den Import massiv. Während bei einer Rastergröße von einem Zentimeter die einzelnen Höhenpunkte nur einen Zentimeter voneinander entfernt sind sind sie bei einer Rastergröße von zwei Zentimeter doppelt so weit voneinander entfernt, benötigen also doppelt soviel Fläche. Folgendes Beispiel, bei dem die gleiche Heightmap einmal bei einem 1 cm Raster und bei einem 2 cm Raster importiert wurde, mag dies verdeutlichen:


Nach einem Klick auf OK wird unsere Platte automatisch durch das Graustufenbild modelliert. Nur noch ein wenig Farbe aufgetragen: Fertig ist unser Bergpanorama mit einem relativ natürlichen Aussehen:

Und nun viel Spaß beim Erschaffen von Bergen. Verbesserungswünsche, Fehler, Änderungen usw. sind gerne per PN im Forum gesehen.

Herzliche Grüße
Franz

9. Tipps und Tricks

In diesem Bereich möchte ich Tipps und Tricks sammeln die sich im Laufe der Zeit finden werden.

Parameter auf der linken Seite verschwunden:

Durch einen falschen Klick an falscher Stelle kann es vorkommen, dass die Parameterliste auf der linken Seite verschwindet. Ärgerlich wenn es kurz vor der Fertigstellung eines Objektes geschieht. In diesem Fall genügt es, das Objekt zu löschen und über "Hinzufügen / Mesh, Landscape" ein neues Objekt einzufügen. Das neue Objekt wird mit den zuletzt aktuellen Parametern erstellt. Dies funktioniert auch wenn vorher "Datei / Neu" ausgeführt wird. Die eingestellten Parameter gehen nur verloren wenn Blender beendet und neu gestartet wird.