• Deutsch
  • English

Überblick über die Versionsänderungen

Inhaltsverzeichnis

Aktuelle Version
3D-Modellbahn Studio V4

Vorgängerversionen
3D-Modellbahn Studio V3
3D-Modellbahn Studio V2
3D-Modellbahn Studio V1

3D-Modellbahn Studio V4

Version 4.2.4.0 vom 5.4.2018

  • Das Standard-Gleis wurde erneuert. Die Schienen sind nun schmaler und basieren auf einem UIC-60-Profil, wodurch die Gleise deutlich näher an der Realität sind.
  • Beim Einfügen von Gruppen/Modulen aus dem Online-Katalog in die Anlage wurde mitunter eine falsche Skalierung angewendet.
  • Das Importieren von Höhenfeldern (Bitmaps) für Bodenplatten besaß ein Problem mit verschiedenen Maßstäben.
  • Bei Verwendung bestimmter Unicode-Steuerzeichen brach der Export der Ereignisverwaltung ab.
  • Kleine Animationsschritte von 3D-Modellen wurden teils zu stark optimiert.

Version 4.2.2.0 vom 5.2.2018

  • Unterstützung der Steuerschnittstelle und der Plugins aus der Vorgängerversion V3. Damit ist nun auch RocStudio mit der neuen Version V4 kompatibel.
  • Unterstützung eines Offline-Modus (Menü Katalog), mit dem der Bauteile-Katalog auf die Festplatte geladen wird und so Anlagen auch ohne Internetverbindung geplant werden können (mit kleineren Einschränkungen).
  • Individuelle Beschleunigung und Bremsverzögerung für Fahrzeuge, konfigurierbar im Eigenschaftsfenster und über die Ereignisverwaltung.
  • Nothalt für Fahrzeuge im Eigenschaftsfenster, mit dem ein Fahrzeug sofort gestoppt werden kann (zweifacher Klick auf die Stopp-Schaltfläche).
  • Neue Aktion in der Ereignisverwaltung, mit der Fahrspuren einer Weiche/Kreuzung einzeln aktiviert/deaktiviert werden können. Sinnvoll bei komplexen Kreuzungen, deren Spuren nicht mehr sinnvoll in Weichenstellungen unterteilt werden können.
  • Fehler im Zusammenhang mit den Triggern in der Ereignisverwaltung behoben.
  • Die Prüfung auf Gleichheit von Variablen in der Ereignisverwaltung hat manchmal wegen Ungenauigkeiten nicht funktioniert.
  • Die Druckfunktion besaß einen Fehler bei Maßstäben ungleich H0.
  • Rotationen wurden im Eigenschaftsfenster manchmal falsch angezeigt (NaN).
  • Gruppen verschwinden nicht mehr unterhalb der Bodenplatte bei Verwendung der automatischen Höhenanpassung.

Version 4.1.1.0 vom 14.12.2017

  • Beseitigung von sporadischen Verbindungsproblemen beim Zugriff auf den Online-Katalog. In diesem Zusammenhang gab es einige größere interne Anpassungen, sodass das 3D-Modellbahn Studio nun automatisch zwischen IPv4 und IPv6 wählt und die Downloadgeschwindigkeit verbessert wurde.
  • Beschleunigtes Öffnen von Anlagen mit sehr vielen Kameras
  • Die Maßstabseinstellungen beim Start einer neuen leeren Anlage werden nun gespeichert
  • Die manuelle Eingabe von Höhen bei der Bearbeitung der Bodenplatte hat eine Skalierung der Platte nicht berücksichtigt
  • Manuell skalierte Gleise haben nicht immer angedockt
  • Fehler beim Öffnen mancher Anlagen behoben (z.B. "Neulich in Opas Rumpelkammer")
  • Sporadische Fehler beim Zuweisen von Objekten zu anderen Ebenen behoben
  • Fehlende Animationen von Entkupplungsgleisen behoben

Version 4.1.0.0 vom 27.11.2017

Die neue Version V4 steht unter dem Motto Vereinfachung. Dabei geht es vorrangig um das Vereinheitlichen und Zusammenfassen der vielen Planungs- und Simulationsfunktionen, mit dem Ziel, noch größere und detailreichere Anlagen zu bauen, ohne dabei die Bedienbarkeit zu beeinträchtigen. Eine kurze Einführung in die neuen Funktionen gibt es in diesem Artikel.

Allgemeine Neuerungen

  • Parallele Installation zu Vorgängerversionen, inkl. automatischer Datenübernahme
  • 64-Bit-Version für extrem speicherhungrige Anlagen

Katalogneuerungen

  • Vollständige Neuentwicklung
  • Strikte Trennung zwischen Benutzer- und Online-Katalog
  • Benutzerkatalog
    • Enthält alle eigenen Inhalte, kann beliebig mit Unterkategorien erweitert werden
    • Favoriten, um beliebige Inhalte (auch Online-Inhalte) an zentraler Stelle zu verwalten
  • Online-Katalog
    • Dynamische Suchanfragen an den Server (wie eine Suchmaschine)
    • Erweiterte Such- und Filtereinstellungen, die für eine spätere Verwendung als Verknüpfung in den Favoriten gespeichert werden können
    • Schlagwörter, zur zusätzlichen Katalogisierung von Inhalten über Kategoriegrenzen hinweg
    • Sets, um auf verwandte Inhalte aufmerksam zu machen
  • Bewertung von Inhalten per "Gefällt mir" und Kontingente
    • Anlagen werden ohne redaktionelle Prüfung automatisch freigegeben, allerdings hat jeder Nutzer nur ein bestimmtes Kontingent, was durch das Sammeln von "Gefällt mir" steigt
    • Je mehr "Gefällt mir" ein Nutzer erhält, umso höher steigt sein Rang, der das Upload-Kontingent beeinflusst (eine Übersicht liefert das Benutzerkonto im Studio), siehe dazu auch Häufige Fragen und Antworten
    • Die Anzahl der "Gefällt mir" und die Downloads der letzten 30 Tage können im Eigenschaftsfenster des Inhalts eingesehen werden
    • Gut bewertete Inhalte werden bei Suchanfragen bevorzugt
  • Entwürfe
    • Es gibt keine Test-Kategorie mehr, sondern eine explizite Veröffentlichung als Entwurf, auch für Anlagen und alle anderen Inhaltstypen
    • Entwürfe werden nach 30 Tagen automatisch gelöscht und nicht im Online-Katalog gelistet. Sie können nur über die Content-ID gefunden werden. Das erlaubt eine "private" Teilung von Inhalten bis zur Fertigstellung des Entwurfs.

Neuerungen für 3D-Modelle

  • Alle 3D-Modelle können frei skaliert werden, auch Bodenplatten und Gleise
  • Unterstützung von Kontaktpunkten für alle Objekttypen, inkl. dem Einrasten auf Gleisen
  • Unterstützung von Variationen zum Zusammenfassen ähnlicher 3D-Modelle zu einem Eintrag
  • Unterstützung von Tauschtexturen zur benutzerdefinierten Anpassung speziell dafür vorbereiteter 3D-Modelle
  • Unterstützung von Splines: Mit Hilfe der neuen Gleisfunktionen können auch normale 3D-Modelle entlang eines Splines verlegt und über den Modifikator als "Flexgleis" gebogen werden
  • Automatische Höhenanpassung an Bodenplatten orientiert sich nicht mehr an der Unterseite eines Modells, sondern am Koordinatenursprung. Somit können z.B. Modelle mit einem "Keller" oder schwebend gebaut werden
  • Neue Seite im Eigenschaftsfenster, die grundlegende Informationen über das selektierte Objekt (Größe, Polygondaten usw.) anzeigt
  • Bewertungen für 3D-Modelle
    • Das Studio analysiert jedes 3D-Modell und gibt Hinweise zu Optimierungsmöglichkeiten
    • Nur Modelle ohne Warnungen können in den Online-Katalog hochgeladen werden
  • Rollmaterialänderungen
    • Unterstützung für Kupplungspositionen innerhalb des Modells. Kann z.B. für Zugmaschinen und Anhänger verwendet werden.
    • Vereinheitlichung der Namen von Spezialobjekten
  • Neuer Partikeltyp "Exponentiell", der besonders bei Dampfloks schönere Ergebnisse liefert
  • Die Textausrichtung von Beschriftungsobjekten beeinflusst nun auch die Textpositionierung: Ein linksbündiger Text startet immer linksbündig an der Position des Beschriftungsobjekts. Damit lassen sich leichter Tabellen aufbauen.
  • Alle Konventionen für den 3D-Modellbau sind im neuen Modellbau-Wiki zu finden

Gleis-Neuerungen

  • Vollständige Neuentwicklung
  • Gemeinsame Basis für Gleise, Straßen, Wasser- und Luftwege
  • Beliebige Maßstäbe/Spurweiten
  • Beliebige 3D-Modelle für Gleise/Straßen sowie Unterstützung von Variationen und Tauschtexturen, Animationen, LOD und allen Funktionen normaler 3D-Modelle
  • Beliebige Spuren (keine feste Unterteilung in Weichen, Kreuzweichen, Dreiwegweichen usw.) mit beliebiger Geometrie
  • Jedes gerade/gebogene Gleis kann nun über den Modifikator flexibel gebogen werden und wird automatisch in ein Flexgleis konvertiert
  • Beliebige Weichenstellungen mit beliebigen Aktionen
  • Neue 3D-Modelle für animierte Drehscheiben, Schiebebühnen und Klappbrücken

Maßstabsänderungen

  • Unterstützung beliebiger Maßstäbe zwischen 10:1 und 1:1000
  • Bei Verwendung von 1:1 oder größer werden alle Modelle im gleichen Maßstab interpretiert (z.B. für rein virtuelle Spieler)

Grafikverbesserungen

  • Der Detailgrad (Umschaltpunkt der Detailstufen sowie das Ausblenden von Objekten in der Ferne) kann in den Einstellungen konfiguriert werden, um auch bei etwas schwächeren Systemen die Performance zu erhöhen
  • Sanftes Ausblenden von Objekten, wenn diese aus der Sichtweite geraten
  • "Zoom unter Mauscursor" für 2D- und 3D-Kameras
  • Standardmäßige Umkehrung der Kamerabewegung (gleiches Verhalten wie bei Blender/3D Studio Max). Kann in den Einstellungen deaktiviert werden.
  • Bessere Glanzlichter (die Szene von Version V3 war überbelichtet)
  • Beseitigung von schwarzen Rändern bei Objekten mit Aussparungen (z.B. Hintergründen)
  • Alpha-To-Coverage = Kantenglättung bei Objekten mit Aussparungen (ab DirectX 10)
  • Reverse-Z-Verfahren = Verringerung von Artefakten und Flimmern bei sich überlappender Geometrie
  • Beschleunigung des Tiefenschärfe-Spezialeffekts

Entfernungen/Zu berücksichtigen

  • Geschwindigkeiten im Studio werden ab V4 immer in km/h angegeben, unabhängig eines Maßstabs. Für den Nutzer ist eine Angabe von 60 km/h verständlicher als 17,34 mm/s. Da das Studio alte Angaben nicht automatisch konvertieren kann (z.B. Aufgrund der Verwendung von Geschwindigkeitsvariablen), gibt es einen internen Geschwindigkeitsmultiplikator, mit dem das Verhalten von V3 emuliert wird. Die Emulation kann in den Anlageneinstellungen deaktiviert werden, wobei dann alle Geschwindigkeitsangaben angepasst werden müssen. Siehe dazu auch Häufige Fragen und Antworten
  • Keine Unterstützung alter 3D-Eisenbahnplaner-Anlagen mehr. Diese können weiterhin in Version V3 geladen, abgespeichert und somit nach V4 konvertiert werden.

3D-Modellbahn Studio V3

Version 3.1.9.0 vom 11.2.2018

  • Probleme beim Start der Steuerschnittstelle behoben, falls die Ports bereits anderweitig in Verwendung sind
  • Archivierung des Online-Katalogs für Version V3

Version 3.1.7.0 vom 14.3.2017

  • Entfernung von Größenbeschränkungen beim Speichern von Anlagen
  • Export eigener 3D-Modelle im OBJ-Format (ohne Materialinformationen), um z.B. ältere 3D-Modelle neu aufzubereiten
  • Kleinere Fehlerbehebungen

Version 3.1.3.0 vom 5.10.2016

  • Zurücksetzen von Kränen per Ereignisverwaltung
  • Verbesserte Performance in der Ereignisverwaltung beim Zugriff auf Objekte per Name/Variable
  • Es erscheint eine Rückfrage beim Abbrechen der Ereignisverwaltung, falls Änderungen vorgenommen worden
  • Gleise behalten ihre Objektvariablen bei, wenn das Gleis im Editor bearbeitet wurde
  • Das Variablenfenster für Objekte kann in der Größe verändert werden
  • Ein Doppelklick auf einen Drehregler setzt diesen auf die Mittelstellung zurück
  • Der Name der Standardebene kann nun angepasst werden
  • Probleme mit der neuen Direct3D 11-Schnittstelle unter Windows Vista und einigen älteren Grafikkarten behoben
  • Videoaufzeichnungen berücksichtigen nun die Einstellung "Automatische Sichtweitenoptimierung"

Version 3.1.1.0 vom 6.6.2016

Warentransport

  • Das 3D-Modellbahn Studio unterstützt nun echte Kräne, die beliebige Waren aufnehmen und wieder absetzen können. Ein Kran ist ein animiertes 3D-Modell, welches entweder manuell per Maus oder automatisiert per Ereignisverwaltung/Steuerschnittstelle angesteuert werden kann. Wie so ein Warentransport ausschauen kann, demonstriert dieses YouTube-Video. Vielen Dank an Franz, der diese Erweiterung angeregt hat.
  • Ein Kran kümmert sich automatisch um alle Verknüpfungen mit dem Transportgut, sodass die Steuerung lediglich aus einfachen Befehlen besteht, wie "Transportgut anheben" und "Transportgut absetzen". Der maximale Einflussbereich wird im Planungsmodus visuell dargestellt.
  • Im Katalog finden sich bereits in der Kategorie Landschaft/Industrie/Kräne 3D-Modelle, die die neuen Funktionen unterstützen. Zusätzlich können die 3D-Modelle Abstellfläche und Abstellfläche (transparent) als Platzierungen auf Bodenplatten oder Wagons genutzt werden. Dafür einfach die Flächen auf die Anlage ziehen und z.B. mit einem Wagon verknüpfen. Wird die Fläche anschließend als Ziel eines Krantransports ausgewählt, transportiert der Kran ein gewähltes Transportgut automatisch zum Ziel und verknüpft es. Alternativ können auch Waren selbst als Ziele dienen, um z.B. Container übereinander zu stapeln.
  • In den experimentellen Anlagen findet sich eine Beispielanlage Zugunabhängiger Warentransport, die die neuen (automatisierten) Kranfunktionen demonstriert
  • Eine Dokumentation zum Bau eigener Kranmodelle ist im Wiki zu finden

Performance-Optimierungen

  • Unterstützung von Direct3D 11. Die 3D-Engine des 3D-Modellbahn Studios nutzt nun standardmäßig die deutlich modernere Direct3D 11-Schnittstelle, statt wie bisher Direct3D 9. Das führt zu einer verbesserten Performance, besonders wenn Anlagen viele Objekte enthalten. Unterstützt die Grafikkarte kein Direct3D 11, wird automatisch die alte Direct3D 9-Schnittstelle verwendet.
  • Animierte 3D-Modelle führen nicht mehr zu zusätzlichen Unterobjekten, werden also schneller verarbeitet. In diesem Zusammenhang gibt es den Begriff "Unterobjekt" offiziell im Studio nicht mehr, da allein die Anzahl der verwendeten Materialien (Texturen, Farben) über die Verarbeitungsgeschwindigkeit eines 3D-Modells entscheidet.

Weitere Änderungen

  • Das Gizmo kann im Planungsmodus optional im Menü "Ansicht" deaktiviert werden
  • Modellanimationen, die den Namen _Time besitzen, werden automatisch mit der Simulationszeit synchronisiert. Damit können 3D-Modelle erstellt werden, die in der Anlage die Simulationszeit anzeigen.
  • Erweiterung von _RandomX, sodass per _RandomX-Y auch ein Bereich zwischen X und Y angegeben werden kann
  • Die Katalog-Datenbank kann in den Einstellungen exportiert bzw. gesichert werden. Es werden dabei nur die eigenen Inhalte in einer Zip-Datei archiviert, die bei Bedarf auch wieder zurückgespielt werden können. Dies erleichtert das Sichern der eigenen Anlagen und 3D-Modelle, ohne das gesamte Katalogverzeichnis kopieren zu müssen.
  • Erhöhung der maximalen Katalog-Cache-Größe auf 2 GB
  • Neues Schnittstellenkommando 133, um die Katalog-ID eines Objekts auf der Anlage zu ermitteln
  • Gleismodelle ohne Bettung besaßen eine andere Höhe als Gleise mit Bettung

Version 3.0.3.0 vom 22.2.2016

Diese Version markiert den Start des 3D-Modellbahn Studios V3, welches die Version V2 ablöst. Ab sofort fließen alle neuen Funktionen und Verbesserungen in die neue Version ein. Wie immer steht das Update für alle kostenfrei zur Verfügung, lediglich neue Funktionen müssen durch ein Upgrade erworben werden. Das Upgrade wird für bestehende Nutzer zur einem reduzierten Preis angeboten (weitere Informationen). Alle Nutzer, die die Professional-Version V2 im 3D-Modellbahn Studio nach dem 1.1.2016 erworben haben, erhalten automatisch Zugriff auf die neuen Funktionen.

Die Änderungen im Überblick:

  • Verbesserte Simulationsfunktionen:
    • Schalter, Signale und Weichen können nun statt mit der Leertaste direkt per Doppelklick geschaltet werden. Im Simulationsmodus können Loks mit der Maus angeschoben und Drehregler direkt in der Anlage gedreht werden.
    • Die Simulation kann optional in verschiedenen Geschwindigkeiten abgespielt werden.
    • Alle Einstellungen zur Simulation werden pro Anlage gespeichert.
  • Unterstützung einer automatisch fortlaufenden Simulationszeit, zwischen 0 und 24 Uhr, um echte zeitabhängige Abläufe zu planen und zu simulieren (Menü "Ansicht" - "Zeiteinstellung"). Auf eine sich ändernde Zeit kann in der Ereignisverwaltung reagiert werden. Damit einher geht die Entfernung des Nachtmodus und der Glühbirne als Lichtposition. Die Helligkeit und der "Sonnenstand" sind nun direkt an die Simulationszeit gekoppelt. Damit werden fließende Tag- und Nachtwechsel ermöglicht.
  • Unterstützung für "echtes" Wasser mit Wellenbewegungen (Option "Wasseroberfläche" im Eigenschaftsfenster für ebene Grundkörper). In diesem Zusammenhang worden die Reflektionen überarbeitet. Sie beschränken sich nun auf die Spiegelung des Himmels, wodurch Reflektionen keinen negativen Einfluss mehr auf die Verarbeitungsgeschwindigkeit haben. Es können beliebig viele Spiegelungen aktiviert werden, ohne einen nennenswerten Performanceeinbruch.
  • 3D-Modelle können ebenfalls die neuen Umgebungsreflektionen nutzen, siehe "_ENV_X" im Modellbau-Wiki
  • Aktivierung von "Per-Pixel-Lighting" für 3D-Modelle, was eine bessere Darstellung bei Objekten mit Glanzpunkten ermöglicht
  • Weit entfernte Objekte werden nicht mehr "hart abgeschnitten", sondern verlieren sich im Nebel
  • Dynamische Partikelsysteme berücksichtigen nun auch die Emitter-Rotation für die Bewegungsrichtung eines Partikels
  • Entkupplungsgleise erzeugen ein Ereignis, auf das in der EV reagiert werden kann
  • Der Gleiseditor zeigt nun die tatsächliche Länge von Flexgleisen an
  • Optionale Deaktivierung der vorderen und/oder der hinteren Kupplung von Rollmaterial per Eigenschaftsfenster, per Ereignisverwaltung oder per Steuerschnittstelle (Kommando 374, 375)
  • Neue Standard-Gleistextur. Passend dazu gibt es eine neue Geländetextur "Schotter (Standard)" für nahtlose Übergänge zwischen Gleis und Gelände
  • Optionales "Leuchten" für Beschriftungsobjekte
  • Direktes Umbenennen von Objekten im Selektionsfenster
  • Kamera-Schnellzugriffe können per Tastatur (0-9) aktiviert werden
  • Steuerung des Öffnungswinkels von benutzerdefinierten Kameras zusätzlich per Mausrad (+STRG für Feinabstimmungen)
  • Der Startbereich ("Zuletzt geöffnet") zeigt keine ausgeblendeten Anlagen mehr an
  • Problem beim Laden von Bodenplatten behoben, die nicht mehr vorhandene Texturen referenziert haben
  • Neue Schnittstellenkommandos 54 und 55, um den Simulationsmodus abzufragen/zu aktivieren
  • Neues Kommando 70, um alle Countdowns in der EV zu ermitteln
  • Neues Kommando 71, um für einen aktiven Countdown die Restlaufzeit zu ermitteln
  • Kommando 153 unterstützt nun auch Werte zwischen 0 und 1, um eine Animation auf eine bestimmte Position zu setzen
  • Fehler bei der Bearbeitung von Gruppenkommandos (Steuerschnittstelle) behoben

3D-Modellbahn Studio V2

Version 2.4.1.0 vom 21.10.2015

  • Das Transformationsmenü im Eigenschaftsfenster besitzt nun einen zweiten Modus (Schlosssymbol), mit dem wahlweise Transformationsänderungen einzeln auf jedes selektierte Objekt angewendet werden. Damit können mehrfach selektierte Objekte z.B. an einer Linie ausgerichtet werden.
  • Optionales Filtern der Stückliste nach Ebenen
  • Geteilte Online-Inhalte, die noch auf die redaktionelle Freigabe warten, werden nun gesondert im Katalog-Statusfenster aufgelistet
  • Kleinere Design-Anpassungen. In diesem Zusammenhang wurden die Lizenznamen der Professional-Versionen von Jahreszahlen auf laufende Nummern geändert (2014 -> V1, 2015 -> V2)
  • Reduzierung der CPU- und Grafikkartenauslastung bei minimierten Fenster
  • Probleme beim Start von Plugins in Verbindung mit verschiedenen Firewalls behoben
  • Probleme beim Laden von Bodenplatten behoben, die keine Standard-Holztextur verwendet haben
  • Korrekte Darstellung extrem kurzer Gleise
  • Sporadisch auftretende Verbindungsprobleme beim Hochladen neuer Inhalte behoben

Version 2.4.0.0 vom 27.8.2015

  • Grundkörper können zu einem "Leuchtkörper" umgewandelt werden, sodass sie auch im Dunkeln leuchten (neuer Materialbereich im Eigenschaftsfenster)
  • Zugriff auf Beschriftungstexte per Variable: Objektname._Text
  • Optionales Setzen der Ist-Geschwindigkeit für die Aktion "Lok-Geschwindigkeit setzen"
  • Im Höhenmodus kann die Höhe nun auch manuell durch Rechenoperationen im Feld "Neue Höhe" gesetzt werden. Unterstützt werden +, -, * und /
  • Die Fixierung von Bodenplatten kann optional auch entfernt werden, wodurch die Platten mit einem einfachen Klick oder per Selektionsrahmen markiert werden können
  • Fixierte Objekte werden bei einer Multiselektion mit STRG nicht mehr durch einen Einfachklick, sondern einem Doppelklick selektiert, um versehentliches Selektieren einer fixierten Bodenplatte zu verhindern
  • Ein Sternchen neben dem Namensfeld zeigt ab sofort an, wenn der Name von mehr als einem Objekt verwendet wird
  • Einführung eines Programms zur Verbesserung des Online-Katalogs. Das 3D-Modellbahn Studio sammelt anonyme Statistiken über die Nutzung der einzelnen 3D-Modelle im Katalog und sendet diese an den Server. Damit soll langfristig die Benutzerfreundlichkeit des Online-Katalogs verbessert werden. Die Funktion kann in den Einstellungen deaktiviert werden.
  • Beschleunigtes Laden sehr großer Anlagen
  • Speicherverbrauch bei Verwendung vieler Grundkörper reduziert
  • Ein Problem beim Import alter EBP-Anlagen (3D-Eisenbahnplaner) behoben
  • Ein Fehler behoben, bei dem die Kamera-Schnellzugriffe in manchen Situationen nicht korrekt gespeichert und geladen worden
  • Gleise behalten beim Ändern der Geometrie ihre Ebenenzugehörigkeit bei

Version 2.3.1.3 vom 22.7.2015

  • Unterstützung von echten Entkupplungsgleisen, die manuell, per Ereignisverwaltung und per Steuerschnittstelle aktiviert werden können und Züge automatisch entkuppeln, wenn diese das Gleis überfahren. Für die bekannten Gleishersteller wurden entsprechende Gleise zum Online-Katalog hinzugefügt. Im Gleiseditor können zudem eigene Entkupplungsgleise generiert werden.
  • In Bodenplatten können nun Löcher für echte Tunnelportale oder Bodendurchbrüche erzeugt werden (neuer Bereich im Eigenschaftsfenster der Bodenplatte)
  • Verwaltung und Speicherung von bis zu 10 individuellen Kameraansichten in der Werkzeugleiste zum Schnellzugriff auf festgelegte Kamerapositionen. Alle Kameras, die freie, die 2D-Kamera, benutzerdefinierte Kameras und Cockpit-Kameras können hinterlegt werden.
  • Ausrichten von benutzerdefinierten Kameras an der aktuellen Kamera
  • Unterstützung von integrierten Schnittstellenprogrammen (Plugins). Die Programme sind nun Teil des Online-Katalogs, werden automatisch aktualisiert und direkt aus dem Studio heraus gestartet, ohne dass diese manuell entpackt werden müssen (Menü "Katalog - Plugins"). Zudem speichert das 3D-Modellbahn Studio, welche Plugins pro Anlage geöffnet waren und startet dieses automatisch beim nächsten Laden.
  • Neues dynamisches Hilfesystem, um die Einführung in das 3D-Modellbahn Studios zu erleichtern. Die Tipps werden bis zu drei mal angezeigt. Das Hilfesystem kann in den Einstellungen deaktiviert werden.
  • Performance-Verbesserungen bei großen Anlagen mit vielen Zügen
  • Filtern von Objekten im Selektionsfenster nach Name
  • Punktgenaues manuelles Positionieren von Modell-Animationen
  • Gleismodifikationen können nun rückgängig gemacht werden
  • Vordefinierte Variable "_RandomX" in der Ereignisverwaltung, wobei X eine beliebige Ganzzahl > 0 ist und eine Zufallszahl zwischen 1 und X zurückliefert
  • Countdown-Auslöser unterstützen in der EV nun auch variable Namen
  • Anpassungen des Schnittstellenkommandos 303: Zusätzlich zur Länge eines Gleises werden auch die Geometriedaten zurückgeliefert, so wie sie im Gleiseditor angegeben werden
  • Optionaler Download des gesamten Online-Katalogs im Offline-Modus für Nutzer, die öfter zwischen beiden Modi wechseln
  • Fehler beim Setzen der Himmelsfarbe in den Lichteigenschaften behoben

Version 2.2.1.0 vom 20.4.2015

  • Cockpit-Kameras können nun auch per Ereignisverwaltung aktiviert werden
  • Die Kameraverfolgung kann nun per Ereignisverwaltung geändert werden
  • Die Funktion "Weiteres Gleis anfügen" funktioniert nun auch korrekt für Flexgleise
  • Optionale Deaktivierung des LOD-Features im Einstellungsdialog ("Automatische Sichtweitenoptimierung")
  • Kommando 100;13 gibt nun keine Cockpit-Kameras mehr zurück, wohingegen Kommando 100;14 der Steuerschnittstelle nun alle Beschriftungsobjekte zurückgibt
  • Kommando 201 interpretiert die Farbwerte nun korrekt als Hex-Angaben
  • Das Verändern der Transformation von Objekten über die Steuerschnittstelle (z.B. Kommando 103) funktioniert nun auch korrekt für Rollmaterial, das auf Gleisen steht
  • Probleme mit mehrbegriffigen Signalen behoben, deren letzter Begriff animiert ist
  • Fehlerhafte Positionierung von Rollmaterial behoben, welches initial auf einem angestellten Gleis liegt

Version 2.2.0.0 vom 9.3.2015

  • Unterstützung von Signalen mit mehr als 2 Signalbegriffen:
    • Signale können in einem neuen Signal-Editor von den Modellbauern mit bis zu 25 verschiedenen Zuständen (Begriffen) belegt werden
    • Signale können mit anderen Signalen (Vor/Hauptsignal) oder mit Weichen verknüpft werden
    • Signale und Weichen können nun ebenfalls mit den Cursor-Tasten geschaltet werden (siehe Tastaturbelegung)
  • Neue und verbesserte Sound-Funktionen:
    • Modellbauer können jedes 3D-Modell mit einer beliebigen Anzahl von Sounds aus dem Katalog ausrüsten
    • In der Kategorie "Zusätzlich" steht ein neues Objekt "Geräuschquelle" zur Verfügung, mit dem beliebige Geräusche (auch aus externen Dateien) auf der Anlage platzieren werden können
    • Alle Sounds werden korrekt in 3D abgespielt, d.h. bei einem 5.1 Soundsystem kommen die Sounds auch aus der korrekten Richtung. Auch Stereo-Lautsprecher profitieren hiervon.
    • Es werden WAV, OGG und MP3-Formate unterstützt
    • Sounds können über die Ereignisverwaltung und über die Steuerschnittstelle angesprochen werden
    • Es stehen neue Geräusche im Online-Katalog zur Verfügung
  • Schalter unterstützen nun ebenfalls mehr als 2 Positionen, falls sie mit einem Signal oder einer Weiche mit mehr als 2 Zuständen verbunden sind
  • Erweiterte Unterstützung von Variablen in der Ereignisverwaltung
    • Alle Objekte können in der Ereignisverwaltung optional auch per Name/Variable angesprochen werden. Dazu auf "Benutzerdefiniert" im Selektionsfenster klicken und anschließend den Namen oder die Variable (beginnend mit $) eintragen
    • Die Animations/Countdownbedingungen und -Aktionen unterstützen nun ebenfalls Variablen (beginnend mit $)
    • Objektnamen in Objektvariablen können nun selbst aus Variablen stammen, indem der Objektname in Klammern gesetzt wird. Beispiel: (Var).Speed referenziert die Variable "Speed" des Objektes, dessen Name in der Variable "Var" enthalten ist. Weitere Informationen im Wiki.
  • Verknüpfen von Objekten per Ereignisverwaltung
  • Das Fenster der Ereignisverwaltung speichert sich die zuletzt geöffneten Ereignisgruppen und das zuletzt selektierte Ereignis
  • Loks drehen sich nun korrekt auf Drehscheiben mit
  • Anpassung der integrierten Prellbockmaßstäbe
  • Gleise docken nicht mehr automatisch an unsichtbare Gleise (anderer Ebenen) an
  • Bodenplatten, die nicht nach "oben" zeigen, werden bei der automatischen Geländeanpassung ab sofort ignoriert. Das verhindert Probleme bei schräg positionierten Bodenplatten.
  • Ein Problem behoben, bei dem der Rauch von Loks an der falschen Stelle austrat, nachdem das Lokmodell geändert wurde
  • Experimentelle Unterstützung von Linux und Mac OS X, siehe Wiki-Artikel

Version 2.1.0.0 vom 2.2.2015

  • Unterstützung von Ebenen/Layern zur erweiterten Anlagenplanung, indem z.B. zusammenhängende Bauteile einfach ausgeblendet werden und dadurch der Blick auf darunterliegende Objekte ermöglicht wird. Alle neuen Möglichkeiten und eine ausführliche Beschreibung der Ebenen-Funktionen können im entsprechenden Wiki-Artikel nachgelesen werden. Das neue Ebenenwerkzeug steht auch in der Standard- bzw. Professional-Version V1 zur Verfügung, wobei dort die maximale Anzahl von Ebenen auf 3 beschränkt ist.
  • Getrennt von den Ebenen/Layern können einzelne Objekte nun gezielt ausgeblendet werden (Augensymbol im Eigenschaftsfenster). Die Sichtbarkeit kann zudem per Ereignisverwaltung und per Steuerschnittstelle gesetzt werden.
  • Das Selektionsfenster erlaubt die zusätzliche Filterung nach Sichtbarkeit und/oder Ebene.
  • Unterstützung von mehreren Animationen pro Modell. Jedes animierte Bauteil besitzt nun einen eigenen Bereich im Eigenschaftsfenster, mit dem die Animationen einzeln angesteuert werden. Zudem können die Animationen per Ereignisverwaltung und Steuerschnittstelle getrennt angesprochen werden. Weitere Informationen für Modellbauer zum Erzeugen von Multianimationen können dem Modellbau-Wiki entnommen werden.
  • Ereignisverwaltung: Neues Ereignis "Animation gestartet/gestoppt"
  • Ereignisverwaltung: Neue Bedingung "Countdown ist aktiv"
  • Setzen von Beschriftungen per Ereignisverwaltung und Steuerschnittstelle (Kommando 500, 501, 502)
  • Eingabe von Text mit Autovervollständigung im Ereignisfenster verbessert
  • Statistik-Fenster zur Anzeige der Gesamtpolygonanzahl der aktuellen Anlage (Doppelklick auf die FPS-Anzeige). Das Statistik-Fenster ist für Modellbauer interessant, die sich etwas mehr mit den technischen Interna des 3D-Modellbahn Studios auseinandersetzen möchten.
  • Beschleunigter Programmstart auf Systemen mit einer älteren Festplatte
  • Probleme beim Import von X-Modellen behoben, die aus Blender exportiert wurden. Zusätzlich steht ein angepasster DirectX-Exporter zur Verfügung, mit dem auch Rollmaterial korrekt exportiert werden kann. Weitere Informationen dazu im Wiki.
  • Fehler bei der Ausrichtung von einigen Radgruppen bei Rollmaterial behoben. Zusätzlich funktioniert nun auch die Ausrichtung entlang ansteigender Gleise korrekt, unabhängig der Ausrichtung des Rollmaterials im 3D-Modell.
  • Probleme beim Verknüpfen zweier bereits gedrehter Objekte behoben
  • Probleme bei der Anzeige des kaufmännischen Unds (&) in Katalogtiteln behoben

Version 2.0.0.0 vom 2.12.2014

Diese Version markiert den Start des 3D-Modellbahn Studios V2, welches nach einem Jahr regelmäßiger Aktualisierungen und Verbesserungen die V1er-Version ablöst. Auch 2015 wird es wie angekündigt wieder viele neue Funktionen und Inhalte geben. Alle Änderungen werden ab sofort in die V2er-Version einfließen, wobei Käufer der Professional-Version V1 zu einem stark reduzierten Preis auf die V2er-Version wechseln können. Aber auch Nutzer der Standard-Version profitieren automatisch von Fehlerbereinigungen und Detailverbesserungen. Weitere Informationen über die Update- und Preispolitik können hier entnommen werden.

Die Änderungen im Überblick:

  • Unterstützung von Spezialeffekten für eine noch realistischere Anlagendarstellung, wie z.B. Tiefenschärfe oder Objektivverzerrungen, aktivierbar über den Simulationsmodus. Einige der Effekte stehen auch in der Standard-Version zur Verfügung.
  • Erweiterter Simulationsmodus (Menü "Ansicht"): Die Einstellungen werden nun getrennt nach aktiviertem/deaktiviertem Simulationsmodus gespeichert, sodass zwei getrennte Sets von Einstellungen verwaltet werden können.
  • Minimale Abmessung von Grundkörpern von 1 mm auf 0,1 mm herabgesetzt
  • Optionales Ausblenden des Bodens und der Seitenwände einer Bodenplatte
  • Beim Speichern von Bodenplatten und Grundkörpern im Katalog kann nun das Vorschaubild gedreht werden
  • Anzeige der internen Objekt-ID im Vorschaufenster, sinnvoll, um z.B. Objekte über die Steuerschnittstelle zu erzeugen
  • Neue Schnittstellenbefehle "136" und "137" zum Löschen und Umbenennen von Objekten
  • Neues Schnittstellenereignis "21", welches das Schließen einer Anlage signalisiert
  • Die maximale Gleislänge wurde auf 4 Meter erhöht (in Vorbereitung auf das neue "Thiel Ilm" Gleissystem)
  • Beim Heranzoomen der 2D-Kamera verschwinden nun keine Objekte mehr
  • Der minimale Öffnungswinkel von benutzerdefinierten Kameras wurde auf 1° herabgesetzt, zudem kann über die Tastatur der Blickwinkel in 0,1°-Schritten geändert werden.
  • Probleme beim LOD (Level-Of-Detail) in Kombination mit benutzerdefinierten Kamera-Öffnungswinkeln behoben
  • Probleme beim Platzieren von gruppiertem Rollmaterial/Autos auf Gleisen behoben
  • Probleme beim Überschreiben von externen Modelldateien beseitigt, die zum Zeitpunkt des Überschreibens in Verwendung waren

3D-Modellbahn Studio V1

Version 1.4.2.0 vom 16.10.2014

  • Loskopplung des Online-Katalogs von der Webseite und Transferierung auf einen eigenen Server. Dies beschleunigt deutlich den Download von neuen Anlagen und 3D-Modellen und entlastet zudem die Webseite des 3D-Modellbahn Studios.
  • Die zuletzt verwendeten Modelle erscheinen nun in einer neuen Kategorie "Verlauf". Über das Ansichts-Menü im Katalogfenster kann der Verlauf optional geleert werden.
  • Verbesserter Import von Heightmaps für Bodenplatten. Vorhandene Höhen werden nicht mehr auf 0 zurückgesetzt, falls die Heightmap keine eigene Höhenangabe für die Position besitzt. Zudem kann nun ein optionaler Höhen-Offset für CSV-Dateien angewendet werden.
  • Ein Problem beim Import alter EBP-Anlagen behoben
  • Sporadisch auftretende Probleme beim Laden von Anlagen behoben
  • Probleme mit versetztem Rollmaterial beim Laden von Anlagen und gruppierten Gleisen behoben
  • Probleme beim Einfügen großer Anlage in eine bestehende Anlage behoben

Version 1.4.0.0 vom 15.9.2014

  • Unterstützung eines neuen Objekttyps "Beschriftung", um beliebige Texte in unterschiedlichen Größen, Schriftarten und Farben auf der Anlage zu platzieren. Damit können z.B. noch einfacher Schaltelemente beschriftet werden. Das Beschriftungsobjekt kann im Katalog unter "3D-Modelle - Zusätzlich - Beschriftung - Beschriftung" auf die Anlage gezogen werden.
  • Automatische Anzeige der Gleisnummern in der technischen Zeichnung (Menü Ansicht - Anlage - Gleisnummern anzeigen). Die Größe der Anzeige kann flexibel über die Werkzeugleiste eingestellt werden.
  • Anheften von Kategorien im Startbereich (rechte Maustaste - An Start anheften), um z.B. einen Schnellzugriff auf eine häufig verwendete Gleiskategorie einzurichten
  • Selten verwendete Kategorien können im Katalog nun analog wie normale Objekte versteckt/ausgeblendet werden (rechte Maustaste - Ausblenden)
  • Eigenen Anlagen, 3D-Modellen, Texturen oder Geräuschen kann nun auch direkt im 3D-Modellbahn Studio eine Beschreibung hinzugefügt werden, die oberhalb des Vorschaubildes angezeigt wird. Die Beschreibung kann entweder beim Speichern oder per rechter Maustaste - "Details bearbeiten" gesetzt werden. Zusätzlich kann die Beschreibung einen Link in der Form <a href="//www.3d-modellbahn.de/URL">Linktext</a> enthalten, um z.B. direkt auf einen Beitrag hier im Forum zu verlinken.
  • Erweiterter Vorschaudialog für Anlagen, 3D-Modelle, Texturen und Geräusche mit Weiter/Zurück-Schaltflächen und zusätzlichen Informationen
  • Einführung eines zusätzlichen Bereiches für zuletzt verwendete Anlagen ("Alle zeigen")
  • Neue Kommandos für die Steuerschnittstelle (138, 139, 142) sowie Unterstützung für Gruppenkommandos
  • Steigerung der Verarbeitungsgeschwindigkeit durch Verwendung einer verbesserten 3D-Engine
  • Unterstützung sehr großer Anlagen mit bis zu 4 GB Arbeitsspeicher (nur auf 64-Bit Systemen)
  • Ein Problem behoben, bei dem mitunter veraltete 3D-Modelle nicht erneut aus dem Online-Katalog nachgeladen wurden
  • Fehlerhafte Texturkoordinaten des Grundkörpers "Rampe" behoben

Version 1.3.8.0 vom 28.7.2014

  • Unterstützung von freischwebenden Katalog- und Eigenschaftenfenstern (Menü "Ansicht"). Verbessert die Planung im Mehrbildschirmbetrieb.
  • Unterstützung einer optionalen Baumdarstellung der Kategorien im Katalog-Bereich
  • Schnellere Synchronisation mit dem Online-Katalog
  • Kleinere Unstimmigkeiten beim Bearbeiten eines 3D-Modells behoben
  • Beseitigung von Abstürzen auf manchen Systemen

Version 1.3.2.0 vom 1.7.2014

  • Konfiguration des Datenbankverzeichnisses im Einstellungsmenü, um den Katalog (Anlagen, 3D-Modelle etc...) in einem benutzerdefinierten Verzeichnis zu speichern (siehe Wiki).
  • Unterstützung von Proxy-Servern für die Internetverbindung (konfigurierbar in den Einstellungen).
  • Modellbauer können das Aussehen von Lichtkegeln (z.B. für Rollmaterial) individueller gestalten. Zudem können Flächen unabhängig der globalen Lichtquelle in einer konstanten Helligkeit dargestellt werden (z.B. für Signale und Ampeln). Weitere Informationen dazu im Modellbau-Wiki.
  • Erweiterung der Steuerschnittstelle zum Erzeugen und Duplizieren von Objekten (siehe Kommandos 134 und 135 im Wiki).
  • Startprobleme bei manchen Laptop-Grafikkarten behoben
  • Probleme beim Einfügen von Anlagen mit Countdowns behoben
  • Probleme mit Wagons behoben, deren Räder nicht im Zentrum positioniert sind (z.B. BR 05-Tender)

Version 1.3.0.0 vom 23.5.2014

  • Einführung von Objektvariablen, zur Umsetzung noch realistischerer Betriebsabläufe und zur Vereinfachung der Ereignisverwaltung. Weitere Informationen sind im Wiki zu finden.
  • Unterstützung von alternativen Aktionen, die nur dann ausgeführt werden, wenn die Bedingungen eines Ereignisses NICHT erfüllt sind
  • Optionales Deaktivieren der Andockfunktionen von 3D-Modellen beim Verschieben durch Drücken von "Shift" oder betätigen der neuen Schaltfläche "Automatisches Einrasten"
  • Anpassung der Gesamtgeschwindigkeit eines Zuges, der von mehr als einer Lok gezogen wird. Die Geschwindigkeit ergibt sich nun aus der Summe der maximalen positiven und der minimalen negativen Geschwindigkeit, nicht mehr aus der Summe der Einzelgeschwindigkeiten. Dadurch wird verhindert, dass beim Andocken einer Lok an einen fahrenden Zug die Geschwindigkeit unrealistisch verdoppelt wird.
  • Unterstützung verschiedener Maßstäbe für Modellbauer, siehe dazu das Modellbau-Wiki
  • Beseitigung eines Fehlers, bei dem Loks nicht immer vollständig auf Wagons aufgefahren sind
  • Beseitigung von Rucklern beim Freischalten einer Weiche durch fahrende Loks
  • Beseitigung eines Fehlers beim Suchen nach Objekten im Katalog, die ein Leerzeichen enthalten
  • Fehlerbeseitigung beim Löschen von Objekten aus dem Katalog

Version 1.2.4.0 vom 22.4.2014

  • Einführung von Dummy-Cockpits, sodass jede Lok automatisch immer ein Cockpit besitzt. Existiert kein Cockpit-Modell, so wird die Kamera zumindest in die Mitte der Lok platziert (danke an Franz für die Idee)
  • Zusätzliche Schaltfläche in der Werkzeugleiste, um schnell die Cockpit-Kamera zu aktivieren
  • Grundkörper, die zum Katalog hinzugefügt werden, verwenden nun eine Kopie der referenzierten Texturen.
  • Die Auswahl-Box im Ereignisfenster wurde vergrößert (siehe Beitrag Ereignis/Gruppe Fenstergrösse)
  • Anzeige der letzten Änderung eines Projektes/Modells im Vorschaufenster

Version 1.2.3.1 vom 8.4.2014

  • Einführung eines Offline-Modus, bei dem keine Katalog-Inhalte automatisch herunter- oder hochgeladen werden (Voraussetzung für das Erscheinen des 3D-Modellbau Studios auf DVD für Nutzer ohne geeignete Internetverbindung).
  • Manuelles Hinzufügen von Variablen in der Ereignisverwaltung
  • Erhöhung der maximalen Texturskalierung für die Bodenplatten
  • Durchsichtige Modelle reagieren nun nicht mehr auf Mausklicks (wichtig für einseitige Hintergründe)
  • Kleine Usability-Verbesserungen
  • Ergänzung:
    • Fehler bei der Selektion mancher Modelle beseitigt

Version 1.2.1.0 vom 27.3.2014:

  • Einführung einer 3D-Vorschau für alle Objekte im Katalog (per Doppelklick)
  • Einführung eines Modell-Editors zur besseren Kontrolle und Konfiguration von eigenen 3D-Modellen
  • Unterstützung von Level-of-Detail-Funktionen bei der Darstellung von 3D-Modellen zur Beschleunigung von komplexen Anlagen. Weitere Details für Modellbauer gibt es im Wiki.
  • Direktes Einfügen von 3DS- oder X-Dateien auf die Anlage ohne über den Katalog zu gehen (sinnvoll beim Bau und schnellem Test von eigenen 3D-Modellen)
  • "Ersetzungsfunktion" (Menü - Bearbeiten - Ersetzen) zum komfortablen Ersetzen von vorhandenen Objekten/Fragezeichen auf der Anlage durch beliebige Objekte aus dem Katalog
  • Beschleunigung der Funktion "Gelände anpassen"
  • Verbesserte Unterstützung älterer Grafikkarten
  • Kleinere Fehlerbehebungen

Version 1.2.0.1 vom 15.3.2014:

  • Unterstützung der Selektion von Unterobjekten innerhalb einer Gruppe, z.B. zum Bearbeiten oder Verknüpfen in der Ereignisverwaltung ohne die Gruppe vorher auflösen zu müssen.
  • Neue Aktion in der Ereignisverwaltung: Betätigen eines Kippschalters
  • Unterstützung einer Kommentarfunktion für Ereignisse und Ereignisgruppen in der Ereignisverwaltung
  • Einführung eines Zuweisungsoperators (=), um Variablen in der Ereignisverwaltung explizit mit negativen Werten initialisieren zu können (siehe Wiki)
  • Neue Kommandos für das Setzen und Auslesen von Variablen über die Steuerschnittstelle (Kommando 60, 61 und 62, siehe Wiki)
  • Sporadischen Fehler in Verbindung mit Bahngebäuden behoben

Version 1.1.4.1 vom 26.2.2014:

  • Offizielle Unterstützung einer englischen Sprachversion des 3D-Modellbahn Studios aufgrund einiger Anfragen aus dem Ausland
  • Falsche Auswertung der Bedingung "Ereignis/Gruppe ist aktiviert/deaktiviert" behoben
  • Ein Problem behoben, bei dem Gesschwindigkeitsänderungen im Eigenschaftenfenster von Loks fälschlicherweise übernommen wurden

Version 1.1.4.0 vom 16.2.2014:

  • Unterstützung des Vollbildmodus
  • Stehendes Rollmaterial bleibt nun mit dem Gleis verbunden, wenn das Gleis verschoben oder gedreht wird (in Vorbereitung auf die neuen Drehscheiben und Schiebebühnen)
  • Erweiterung der Steuerschnittstelle (Kommando 80). Praktisches Anwendungsbeispiel: Video-Aufzeichnung beliebiger Anlagen ohne Ruckler
  • Fehler behoben, bei dem der Blickwinkel von benutzerdefinierten Kameras nicht gespeichert wurde
  • Fehler behoben, bei dem kleine Änderungen der Lok-Geschwindigkeit nicht übernommen wurden

Version 1.1.3.1 vom 9.2.2014:

  • Bessere Unterstützung von Grundkörpern: Grundkörper können nun Texturen außerhalb des Katalogs referenzieren. Gruppen von Grundkörpern können als zusammenhängendes 3D-Modell dem Katalog hinzugefügt werden. Die Abmessungen im Eigenschaften-Fenster berücksichtigen nun auch die Skalierung, wodurch die Größe immer in absoluten Werten eingegeben wird.
  • Erzeugen benutzerdefinierter Steuerobjekte aus eigenen 3D-Modellen (z.B. als Kippschalter/Drehregler)
  • Die Größe und Position des Selektionsfensters ist nun variabel und wird gespeichert
  • Probleme mit Bedingungen behoben: Signalbedingungen trafen manchmal nicht zu, "Lok/Wagon steht auf einem Gleis" berücksichtigt nun das gesamte Modell und nicht mehr nur die Mitte.

Version 1.1.1.0 vom 26.1.2014:

  • Ereignisverwaltung 2.0: Neue und überarbeitete Ereignisverwaltung mit noch mehr Funktionen: Bedingungen mit logischen Operationen (AND, OR, NOT), Einführung eines Variablensystems für Zähler und benutzerdefinierte Zustände, Export der Ereignisse als HTML- oder XML-Datei, bessere Übersicht über aktive Countdowns und Variablen. Der Wiki-Artikel Ereignisverwaltung gibt einen detaillierten Einblick in alle Funktionen.
  • Veröffentlichung der Steuerschnittstelle zur Anbindung externer Programme an das 3D-Modellbahn Studio. Im Wiki gibt es weitere Informationen. Zudem steht ein neues Unterforum zur Verfügung, welches Beispielprogramme für die Steuerschnittstelle für verschiedene Programmiersprachen enthält.
  • Objekte aus dem Katalog werden nun automatisch auf die korrekte Spurweite skaliert, wenn sie auf die Anlage gezogen werden. Diese Einstellung kann auch manuell über das Menü bzw. die Werkzeugleiste vorgenommen werden. Diese Funktion sorgt für einen einheitlichen Maßstab bei Verwendung anderer Spurweiten als H0.
  • Die Geschwindigkeiten von Loks können im Eigenschaften-Fenster zusätzlich über Hoch/Runter-Schaltflächen in kleineren Abständen justiert werden.
  • Herabsetzen der Mindestanforderung an die Grafikkarte, sodass auch ältere Grafikkarten (Shadermodell 2.0) unterstützt werden.
  • Mehrere Fehler behoben

Version 1.0.6.2 vom 3.1.2014:

  • Beim Andocken von Straßen wird die ursprüngliche Rotation berücksichtigt, sodass auch angestellte Straßen angedockt werden können (z.B. zur Umsetzung von Bergstraßen)
  • Beseitigung eines Geschwindigkeitsproblem bei Anlagen mit vielen Gleisen
  • Darstellungsprobleme bei Führerstands-Ansichten behoben

Version 1.0.6.1 vom 29.12.2013:

  • Beschleunigtes Laden großer Anlagen. Beispiel: Große Märklin Anlage von 67 auf 7 Sekunden, Meine Landschaft von 38 auf 9 Sekunden.
  • Ein Problem wurde behoben welches manchmal dazu führte das Loks ihre Wagons verloren
  • Kleinere Fehler beseitigt

Version 1.0.6.0 vom 19.12.2013:

  • Einführung eines neuen Objekttyps, dem Partikeleffekt, zur realistischen Darstellung von Wasserdampf, Schnee, Feuer, Wolken und vieles mehr. Weitere Informationen gibt es in diesem Beitrag.

Version 1.0.5.2 vom 14.12.2013:

  • Unterstützung von ereignisgesteuerten Kameras
  • Fehler beim Öffnen einiger Anlagen behoben

Version 1.0.5.0 vom 9.12.2013:

  • Unterstützung benutzerdefinierter Führerstand-Ansichten mit freier Kameradrehung. Die Loks Blaue Dampflok, Braune Damplok, Württemberger, Diesellok (rot), Diesellok (weiß), Tegernsee, ICE, E-Lok (weiß), E-Lok (grün), E-Lok (klein), und E-Lok (silber) besitzen bereits vordefinierte Führerstand-Ansichten. Mittels der rechten Maustaste kann die Kamera im Führerstand gedreht werden.
  • Einfügen vorhandener Anlagen und Ereignisse in die aktuell geöffnete Anlage über "Menü" - "Bearbeiten" - "Einfügen aus" - "Anlage"
  • Katalog-Einträge können nun im Studio ausgeblendet werden, siehe dazu diesen Beitrag
  • Die Anzeige des Selektions-Fensters wurde beschleunigt
  • Fehler beim Stoppen von Zügen an Prellbockgleisen behoben
  • Kleinere Fehlerbeseitigungen

Version 1.0.3.0 vom 4.12.2013:

  • Unterstützung von Straßenelementen mit benutzerdefinierten Andockpunkten, siehe auch diesen Beitrag

Version 1.0.1.0 vom 1.12.2013:

  • Erste öffentliche Version des neuen 3D-Modellbahn Studios